Performance degradation
Resolved·Degraded performance

A fix has been applied to address the performance degradation experienced earlier this morning. Response times have returned to normal levels and all services are operating as expected.

We apologize for any inconvenience caused

Mon, Feb 2, 2026, 12:32 PM
(2 days ago)
·
Affected components
Updates

Resolved

A fix has been applied to address the performance degradation experienced earlier this morning. Response times have returned to normal levels and all services are operating as expected.

We apologize for any inconvenience caused

Mon, Feb 2, 2026, 12:32 PM

Investigating

We're currently experiencing intermittent slowness affecting the Younium EU platform. Some users may notice delayed page loads and slower API response times.

Our team has identified the issue as increased load during peak hours and is actively working to restore normal performance.

We apologize for any inconvenience and will provide updates as we progress.

Mon, Feb 2, 2026, 10:22 AM(2 hours earlier)
Powered by