Service degradation
Incident Report for Younium (EU)
Resolved
The incident has been resolved and we have received confirmations from users that Younium is again accessible. This is the latest update from Microsoft on the topic:

Azure Services - West Europe - Applying Mitigation

Impact Statement: Starting at 07:31 UTC on 20 October 2023, we've determined a power event has impacted a subset of infrastructure in a single Availability Zone in the West Europe region.

Current Status: Power has been restored and the majority of devices are back online. Most customers should be seeing signs of recovery. We are continuing to work to restore the remaining devices to fully recover services.

Updates will be shared as they become available.

This message was last updated at 09:42 UTC on 20 October 2023
Posted Oct 20, 2023 - 11:51 CEST
Update
Microsoft has now added an update to their status page, we are following this incident closely.
https://azure.status.microsoft/en-us/status
Posted Oct 20, 2023 - 10:34 CEST
Investigating
We are currently investigating this issue. Multiple partners has reported high latency or outage with Microsoft Azure Data Centre West Europe that Younium uses. We will provide more details as soon as possible.
Posted Oct 20, 2023 - 09:58 CEST
This incident affected: Younium Service (app.younium.com).