Degraded performance of authentication platform

Incident Report for Younium (EU)

Resolved

This incident has been resolved.
Posted Jul 04, 2025 - 20:31 CEST

Investigating

Our authentication partner is currently experiencing degraded performance. We are investigating and monitoring this issue.
Posted Jul 04, 2025 - 14:22 CEST
This incident affected: Younium Service (app.younium.com) and API.